5 個の投稿 / 0 new
最終投稿
#1 2021-10-12 22:27

nchlshader2 problem

Does anyone know how to stop this ghosting/ artifact glitch? https://ecchi.iwara.tv/images/nchlshader2-glitch It happens when I remove something with a morph (taking the jacket off) The only way I found to fix it currently is to delete the item in pmx editor, but its not ideal.

2021-10-13 00:55

It might be a problem with model draw order. Try going to Background > Model Draw Order and make sure your stage/background is listed above the model you're morphing (Prinz, for example).

2021-10-13 03:37

that's a problem with the "outline".
open the model in the PMX-Editor and disable the "outline" for all materials and also disable the "2-side".
With the 2-side you must be careful to check 1 by 1 so that the material does not disappear.

2021-10-13 03:39

or in the MMD ...
view -> thickness of edge line = 0

2021-10-13 07:57

Thanks for the help. It was the model draw order.

2021-10-13 18:01

In MME, if you remove all effects on the jacket from all the tabs, the black part should disappear. You can't make this happen on the middle of a project though. The best solution I've found is to render in multiple parts.

Or you could make a vertex morph to shrink the jacket into the model's body and hide it that way. Works well on stuff without physics.

EDIT: Nvm, I didn't notice that you already resolved it. I'll leave my reply up, since it might help others with different issues like ghosting from DOF or motion blur effects ^^

2021-10-19 02:30

You could also change the shader's code a bit to fix this.
I made some instructions on how to do that. https://www.iwara.tv/images/nchl-shader-fix-tutorial

With this you can ignore draw order.